RSS

Limit bandwidth IIX di mikrotik

09 Oct

Berawal dari tugas kantor, belum ada bayangan sebelumnya bagaimana konsep ini. Setelah berkonsultasi ke adminnya, ternyata ini cuma sebuah marking aja. Sama seperti marking packet port yang sudah umum di tempat kerja saya. Setelah googling dan eksperimen, ternyata masih belum berhasil masuk di counter yang tertera di winbox. Ternyata tidak di perlukan marking 2 lapis (marking connection lalu marking packet), hanya di perlukan marking packet saja dan sudah berhasil. Ok, berikut bahan-bahan yang perlu di siapkan.

1. PC router OS mikrotik.
2. Internet (bila buntu, tinggal bertanya saja ama ki joko google).
3. Tentu saja manusia sebagai operatornya.

Cara membuat :

1. Pertama kita harus paham dulu dari sebuah konsep firewall mangle. Bisa anda baca di sini.

2. Download IIX address list, yang bisa anda download di sini.

3. Copy file tersebut ke list file di mikrotik dengan menggunakan winbox.

4. File nice.rsc tersebut hanya berisi file yang executable secara otomatis menambahkan list address ke PC router mikrotik kita. Anda juga dapat memodifikasinya untuk keperluan routing. Yang kita perlukan hanyalah mengeksekusi file tersebut dengan cara import.

/import file-name=nice.rsc

5. Setting firewall seperti di bawah ini. Saya 2 kali input karena untuk marking upload dan download.

;;; Mark Packet IIX download
/ip firewall mangle add chain=prerouting action=mark-packet new-packet-mark=iix passthrough=yes src-address-list=nice in-interface=wlan1

;;; Mark Packet IIX upload
/ip firewall mangle add chain=prerouting action=mark-packet new-packet-mark=iix passthrough=yes dst-address-list=nice in-interface=ether1

;;; Mark Packet IX download
/ip firewall mangle add chain=prerouting action=mark-packet new-packet-mark=ix passthrough=yes src-address-list=!nice in-interface=wlan1

;;; Mark Packet IX upload
/ip firewall mangle add chain=prerouting action=mark-packet new-packet-mark=ix passthrough=yes dst-address-list=!nice in-interface=ether1

Note : Dalam hal ini saya gunakan radio router. Maka dari itu terdapat interface wlan1. Bisa di asumsikan wlan1 adalah interface public dan ether1 adalah interface local network.

6. Masukkan rule di simple queue. Di sini juga anda di perlukan mengetahui konsep dari queue di mikrotik itu sendiri. Segala sesuatu tentang queue di mikrotik bisa anda baca di sini.

;;; Limit IIX, download upload simetris
/queue simple add name=IIX target-addresses=192.168.0.0/24 max-limit=1M/1M packet-marks=iix

;;; Limit IX, download 1mbps, upload 512kbps
/queue simple add name=IX target-addresses=192.168.0.0/24 max-limit=1M/512k packet-marks=ix

Voilà, limit pun jadi, counter hitsnya pun menunjukkan aktivitasnya. It feels good for doing something right, just don’t give up…

 
1 Comment

Posted by on October 9, 2011 in Tulisan

 

One response to “Limit bandwidth IIX di mikrotik

  1. Md. Ataur Rahman

    April 21, 2013 at 18:19

    Nice work

     

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

 
%d bloggers like this: